Регистрация/личный кабинет
Обратный связь 0
Модуль Соглашение с условиями для Opencart 2

Модуль Соглашение с условиями для Opencart 2

Совместимость
Opencart 2.0 Opencart 2.1 Opencart 2.2 Opencart 2.3
Цена
200 р.
Категория
Совместимость
Opencart 2.0 Opencart 2.1 Opencart 2.2 Opencart 2.3
Файлы будут доступны после покупки личном кабинете
Описание

Модуль Opencart 2.x позволяет открыть окно, в котором пользователь увидит соглашение с прописанными условиями просмотра работы клиента (или cookie) и использования его личных данных (или privacy policy). В открывшемся окне пользователь прочтет все условия, после чего внизу соглашения он увидит кнопку «Принять». Эта кнопка будет подсвечиваться, пока пользователь не нажмет на нее. В последующие разы форма больше всплывать не будет.

Модуль работает просто и не требуется его настраивать.

Установка модуля:

  1. Скачать и разархивировать файл
  2. Установить через админку - Установка модулей
  3. Обновить модификации
Комментарии
VIP-подписка
Проблемы и решения
1. После установки модуль не появился в списке

Вероятные причины:

  • 1. В случае если ранее не проводилась загрузка модулей через админ-панель, необходимо инсталлировать бесплатное расширение localcopy.ocmod.xml с соблюдением всех рекомендаций, после чего произвести переустановку
  • 2. Инсталляция может не предусматривать наличие отдельной страницы, следовательно ее не будет в числе модулей

2. Ошибка: Необходимо включить FTP в настройках

  • 1. Появление данной проблемы во время инсталляции модуля из админ-панели требует загрузки расширения localcopy.ocmod.xml. Устанавливается оно через дополнения, далее нужно провести обновление модификации, что позволит инсталлировать все дополнения в систему.
  • 2. Второй вариант решения данной ошибки предполагает прописывание в админ-панели соответствующих доступов.

3. Ошибка: Доступ запрещен!

При появлении сообщения из категории «Доступ запрещен!» и уведомления о том, что страница доступна только пользователям с правами администратора, необходимо предоставить соответствующие права. Для этого в админ-панели нужно перейти во вкладку Администраторы, где установить галочки напротив всех пунктов, и нажать кнопку Сохранить

4. Ошибка: Недопустимый тип файла!

Модули, которые содержат только файл с двойным расширением ocmod.xml, заливаются в папку В случае использования архива, не обязательно проводить разархивацию, можно инсталлировать в изначальном виде. В корне должна содержаться пустая или заполненная файлами папка upload, и служебные для установки модификаций. Помимо указанных данных в корневом каталоге архива не должно присутствовать ничего лишнего. Более полную информацию об инсталляции модулей получите здесь.

5. Ошибка: Каталог, содержащий файлы для загрузки не может быть найден!

Возникновение данной ошибки обусловлено отсутствием папки upload. Она непременно должна содержаться в архиве, без исключения для случаев, когда в нем присутствуют только файлы модификации – в этом случае папка будет пустой.

6. Ошибка: Модификатор использует тот же ID код который вы пытаетесь загрузить!

Появление такого сообщения обусловлено попыткой инсталлировать ранее уже загруженный модификатор, либо тот, чей ID совпадает с устанавливаемым. Устранить данную ошибку можно путем удаления ранее загруженной версии в админ-панели. В случае совпадения ID нового модуля с уже существующим, необходимо изменить параметр в новом модификаторе, путем добавления нескольких символов.

7. Ошибка: Warning: DOMDocument::loadXML(): CData section not finished

Появление данной ошибки обусловлено попыткой инсталлировать чересчур большой по размерам xml-модификатор. Суммарное число символов должно находиться в пределах 65535. Устранить данную ошибку можно путем разбивки инсталляционного пакета на компоненты, при этом каждый должен иметь собственный уникальный параметр . Для удобства можно использовать цифры 1,2,3... для каждой части соответственно. Другой вариант исправления ошибки состоит в изменении типа в поля, хранящие модификации, в таблице БД с названием 'oc_modification'. Для этого достаточно задать такой SQL-запрос: ALTER TABLE oc_modification CHANGE xml xml MEDIUMTEXT CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL;

8. Ошибка: Fatal error: Uncaught exception '...' with message '...' in

Данная ошибка появляется в случае инсталляцию в систему с версией от 2.3.x.x такого модуля, который не совместим с новой версией (когда она устаревает). Для устранения данной ошибки необходимо удалить все данные, относящиеся к данному модулю. Максимально быстро сделать это позволяет модуль ХХХХ Другой причиной появления данной проблемы является обращение скрипта к таблице БД, которой не существует. Чаще всего это возникает в том случае, если при инсталляции таблица не была создана. Нужно ознакомиться с правилами инсталляции модуля, и произвести его переустановку при необходимости.

9. Отсутствует реакция модуля

Зачастую при отсутствии требуемой реакции модуля, требуется нажать на любую активную кнопку, чтобы вызвать любую реакцию. Ошибка чаще всего сопряжена с конфликтом в Java-скриптах. Попробуйте также открыть панель вебмастера, нажав кнопку F12. Здесь отображаются существующие конфликты на соответствующей вкладке.

10. Ошибка 500

Появление данной проблемы обусловлено наличием ошибок в коде php. Устранение ее возможно при выполнении следующих действий: 1. Проверить серверный файл ошибок 2. Просмотреть логи в админ-панели. Стоит отметить, что ошибки здесь показываются далеко не все. 3. Прописать в начале php-файла контроллера следующий код для демонстрации на экране возникших проблем: ini_set('error_reporting', E_ALL); ini_set('display_errors', 1); ini_set('display_startup_errors', 1);

Смотрите также
Товары в админке в порядке добавления на Opencart 2
Цена: 199 р.
Оформить
Подробнее
Быстрый заказ / Заказ звонка - модуль Opencart 2
Цена: 199 р.
Оформить
Подробнее
Прикрепление файлов в истории заказа Opencart 2
Цена: 299 р.
Оформить
Подробнее
Подписка на рассылку для Opencart 2.3
Цена: 0 р.
Оформить
Подробнее